Minimum requirements:

1 Most browsers will work. If you are running very old browser software (earlier than the versions mentioned), it is a good idea to update in order to obtain important security and privacy upgrades.